16" Split Rims Run Flats

More
02 Nov 2012 22:02 #1 by dandjcr
dandjcr created the topic: 16" Split Rims Run Flats
Forum Home > On the Road > 16" Split Rims Run Flats

Rodman
Member
Posts: 40
How about for you guys that are runing the 16" Split rims using the US Military Run Flat Device?




April 22, 2011 at 12:22 PM Flag Quote & Reply

oka 098
Member
Posts: 58
Is that the tube or where is the tube ? dont split rims need a tube?
April 22, 2011 at 2:54 PM Flag Quote & Reply

oka 098
Member
Posts: 58
oh yeah no tube ,the edge of tyre wedges against inner ,looking and no thinking ,cheers
April 22, 2011 at 3:18 PM Flag Quote & Reply

Rodman
Member
Posts: 40
Some split rims have a ruber seal in the center and that seals the two halfs, so you do not need a tube.
April 22, 2011 at 3:51 PM Flag Quote & Reply

Peter & Sandra James Oka 374
Member
Posts: 413
Rodman I tried to fit the humvee wheels to the Oka but they have too much offset and foul the body and steering. They are two piece steel rims with beadlock/runflat as per the pic above, problem is they are 16.6" rims and tyres are getting hard to get plus not much choice here in Oz, the only ones available are the 37x12.5x16.5 Nanakangs which have a similar tread pattern to the MT's in the other post in the xml thread.
--
Oka 374 LT Van

April 22, 2011 at 4:18 PM

David and Janet Ribbans - Oka 148
Oka148 profile here.
Visit our technical and travel blogs: here.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum